Adobe Flash Player

RedSeed video files will play natively within Google Chrome, Safari and IE9 and above as well as most mobile devices.

For older browsers like IE8 as well as Firefox our video player (JW Player) requires Adobe Flash to be installed to view the video content. 

On browsers requiring Flash to play videos version 10.0+ is required to play H.264 video files but the latest stable Flash version is preferred.

Please make an effort to keep your flash player version current.

When flash is installed / upgraded ensure that flash and any temporary file locations are available to ALL local user accounts on the PC. 

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us